Collapse

Announcement

Collapse
No announcement yet.

ESMTP server not available [Stofa-15106] - PTR mismatch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ESMTP server not available [Stofa-15106] - PTR mismatch

    SMTP error from remote mail server after initial connection: 554 inb-cm-2 cmsmtp 4ignga6uKwUhz ESMTP server not available [Stofa-15106] - PTR mismatch

  • #2
    Make sure the forward lookup (A record) of the Hostname of the server matches the reverse lookup (PTR) for IP address.

    Forward DNS:
    Click image for larger version

Name:	forward dns.png
Views:	26
Size:	7.6 KB
ID:	809

    Reverse DNS:

    Link to check: https://mxtoolbox.com/ReverseLookup.aspx

    Click image for larger version

Name:	reverse dns.png
Views:	28
Size:	43.2 KB
ID:	810

    If you have changed mail sending IP address due to the recent spamming activity then this may cause SMTP banner mismatch and can give out above error.


    Check the options are as shown in the screenshot below:

    Click image for larger version  Name:	exim.png Views:	1 Size:	69.3 KB ID:	805


    If yes, then you will have to edit your files on the server end with your favorite editor. Kindly replace x.x.x.x with the server’s dedicated IP address or shared IP address and associated RDNS name that you have set at the DC panel.


    root@ [/]# nano /etc/mail_reverse_dns

    ```
    x.x.x.x: dedicated-ip-reverse-dns.domain.com
    x.x.x.x: main-sharedip-reverse-dns.domainhostname.com
    ```

    root@ [/]# nano /etc/mailhelo

    ```
    domain.com: dedicated-ip-reverse-dns.domain.com
    *: main-sharedip-reverse-dns.domainhostname.com
    ```

    Thereafter, edit your /etc/exim.conf:

    Search for this line:

    Code:
    smtp_banner = "${primary_hostname} ESMTP Exim ${version_number} \

    and replace it with below lines:

    Code:
    smtp_active_hostname = ${lookup{$interface_address}lsearch{/etc/mail_reverse_dns}{$value}{$primary_hostname}}
    message_id_header_domain = $smtp_active_hostname
    smtp_banner = "${smtp_active_hostname} ESMTP Exim ${version_number} \

    Restart Exim service and emails should work now and no longer rejected by the remote host.
    Last edited by Mandeep; 09-26-2018, 02:55 PM.

    Comment

    Working...
    X